Demandbase Platform Partial Outage
Incident Report for Demandbase
Resolved
The Demandbase Platform is now Operational. We apologize for any inconvenience this has caused.
Posted Jun 18, 2019 - 15:52 PDT
Investigating
We're experiencing a partial outage of the Demandbase Platform and we are currently investigating the issue.
Posted Jun 18, 2019 - 14:17 PDT
This incident affected: Demandbase Platform.