We are currently experiencing DB1 application load time issues and are working to resolve the issue.
Incident Report for Demandbase
Resolved
We have identified the issue and applied the fix.
Posted Oct 15, 2024 - 10:48 PDT
Investigating
We are currently investigating this issue.
Posted Oct 15, 2024 - 09:59 PDT
This incident affected: Demandbase Platform.