Demandbase login

Incident Report for Demandbase

Resolved

The incident has been resolved.
Posted Sep 14, 2025 - 15:59 PDT

Update

We are continuing to investigate this issue.
Posted Sep 14, 2025 - 15:33 PDT

Investigating

We are aware of an issue with logging into Demandbase and are working with our vendor to fix it.
Posted Sep 14, 2025 - 15:33 PDT
This incident affected: Demandbase Platform.