We are experiencing issues with data loading for few customers since last night. We are looking into it.

Incident Report for Demandbase

Resolved

All customer data is now up to date.
Posted Aug 22, 2025 - 13:04 PDT

Investigating

We are currently investigating this issue.
Posted Aug 22, 2025 - 06:07 PDT
This incident affected: Demandbase Platform.