Slowness in Demandbase

Incident Report for Demandbase

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 15:34 PDT

Monitoring

The site performance has returned to normal. We will continue to monitor it.
Posted Sep 18, 2025 - 09:08 PDT

Investigating

We are aware of performance issues in the Demandbase application. The team is investigating.
Posted Sep 18, 2025 - 08:50 PDT
This incident affected: Demandbase Platform.