Activities from yesterday and Journey Stage updates have not been refreshed for some tenants.

Incident Report for Demandbase

Resolved

All tenants are up to date.
Posted Jun 19, 2025 - 13:58 PDT

Update

We have identified additional issues and are continuing to work on the issue.
Posted Jun 19, 2025 - 07:42 PDT

Identified

We believe we have identified the root cause. We expect all the tenants to be up to date after tonight's refresh.
Posted Jun 18, 2025 - 13:00 PDT

Update

We are continuing to investigate this issue.
Posted Jun 18, 2025 - 09:27 PDT

Investigating

We are currently investigating this issue.
Posted Jun 18, 2025 - 09:27 PDT
This incident affected: Demandbase Platform.