Slowness in Ad Campaigns

Incident Report for Demandbase

Resolved

The issue is resolved.
Posted Sep 09, 2026 - 11:49 PDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2026 - 11:36 PDT

Investigating

We are aware of an issue with the performance of Ad Campaigns and we are investigating.
Posted Sep 09, 2026 - 11:35 PDT
This incident affected: Demandbase Platform.