Demandbase One platform is experiencing login issue and team is investigating

Incident Report for Demandbase

Resolved

The issue is now resolved. We will be conducting a post mortem on this issue.
Posted Feb 09, 2022 - 05:23 PST

Investigating

Demandbase One platform is experiencing login issue
Posted Feb 09, 2022 - 04:23 PST
This incident affected: Demandbase Platform.