Platform Performance Degradation
Incident Report for Demandbase
Resolved
The performance issue has been identified and resolved. Please open a support ticket if you continue to experience performance degradation in the platform.
Posted 6 months ago. Apr 12, 2019 - 12:06 PDT
Investigating
We are experiencing intermittent issues with the ABM Platform causing performance degradations.
Posted 6 months ago. Apr 12, 2019 - 11:53 PDT
This incident affected: Demandbase Platform.