Subscription email delay

Incident Report for Demandbase

Resolved

Our email vendor fixed the problem and we've resubmitted the subscription emails. They should go out in the next couple of hours.
Posted May 27, 2024 - 15:07 PDT

Monitoring

Our email provider is experiencing delays in delivering subscription emails.
Posted May 27, 2024 - 12:50 PDT
This incident affected: Demandbase Platform.