Audience Workbench Latency Incident
Incident Report for Demandbase
Resolved
The Audience Workbench Latency Incident has been resolved
Posted Jan 28, 2020 - 07:26 PST
Identified
We have identified an issue that is causing audiences to load slower than normal. We are currently in the process of implementing a fix and expect to have a resolution in place no later than Wednesday. We apologize for any inconvenience this has caused.
Posted Jan 27, 2020 - 12:29 PST
This incident affected: Demandbase Platform.