Platform Navigation Issues
Incident Report for Demandbase
Resolved
This incident has been resolved and all systems are now functioning normally. We apologize for any inconvenience that this may have occurred.
Posted over 1 year ago. Feb 05, 2018 - 12:18 PST
Investigating
We're experiencing platform UI navigation issues and are currently investigating the problem.
Posted over 1 year ago. Feb 05, 2018 - 09:26 PST